VOL加強(通達信公式 副圖 源碼 測試圖)(圖文)

時間:2019-09-22 13:21:20 作者:admin
後台-系統-系統設置-擴展變量-(内容頁告位1-手機版)

{預測成交量}
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,V*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
{柱體買賣}
DRAWTEXT_FIX(1,0.00,0,0,'白燭建倉★黃燭加倉★粉燭操盤★紅多綠空☆藍燭清倉☆尾綠出貨☆ BY:CHH322')COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.05,0,'')COLOR00FF00;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
買盤:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
賣盤:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
買賣差:=(買盤 + 賣盤);
STICKLINE((VOL > 0),VOL,0,3,1),COLORFFFFFF;
STICKLINE((買賣差 > 0),0,買賣差,3,0),COLOR0000FF;
STICKLINE((買賣差 < 0),0,買賣差,1,0),LINETHICK1,COLOR66FF00;
量比1:=(VOL / MA(VOL,5));
{分析家公式網www.70822.com}
VAR10:=買盤;
VAR20:=賣盤;
JX1:=BARSSINCE(買盤);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
動神:=買盤;
鬼力:=VAR20;
神比:=(動神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,動神) + 動神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,動神) + 動神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,動神) + 動神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多頭:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;
空頭:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLOR00FF00;
STICKLINE((鬼力 > 0),鬼力,0,3,0),COLORFF3399;
加倉:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,3,0),COLOR00FFFF;
減倉:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,3,0),COLORFF0000;
洗盤:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,3,0),COLORFFFFFF;
高賣:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,3,0),COLORFF00FF;
相對地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);
{柱體加注}
量:V,NODRAW;
倍量:(V/REF(V,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.91),NODRAW,COLOR3366FF;
低量:V<=REF(LLV(V,15),1),NODRAW,COLOR7FFF00;
地量:V<=REF(LLV(V,100),1),NODRAW,COLORRED;
平量:ABS(V-HHV(REF(V,1),5))/HHV(REF(V,1),5)<=0.03 OR ABS(V-REF(V,1))/REF(V,1)<=0.03,NODRAW,COLOR824173;
倍縮:V<=REF(V,1)*0.5,NODRAW,COLOR5C3317;
梯量:COUNT(V>REF(V,1),3)=3 AND COUNT(C>O,3)=3,NODRAW,COLOR9932CD;
縮量漲:COUNT(C>REF(C,1),2)=2 AND COUNT(V<REF(V,1),2)=2,NODRAW,COLOR996600;
DRAWTEXT(倍量,V*1.06,'倍'),COLOR3366FF;
DRAWTEXT(低量,V*1.09,'低'),COLOR7FFF00;
DRAWTEXT(地量,V*1.12,'地'),COLORRED;
DRAWTEXT(平量,V*1.15,'平'),COLOR824173;
DRAWTEXT(倍縮,V*1.06,'縮'),COLOR5C3317;
DRAWTEXT(梯量,V*1.18,'梯'),COLOR9932CD;
DRAWTEXT(縮量漲,V*1.21,'縮漲'),COLOR996600;
STICKLINE(倍量,0,V,0.1,0),COLOR3366FF;
STICKLINE(低量,0,V,0.1,0),COLOR7FFF00;
STICKLINE(地量,0,V,0.1,0),COLORRED;
STICKLINE(平量,0,V,0.1,0),COLOR824173;
STICKLINE(倍縮,0,V,0.1,0),COLOR5C3317;
STICKLINE(梯量,0,V,0.1,0),COLOR9932CD;
STICKLINE(縮量漲,0,V,0.1,0),COLOR996600;
{畫線}{分析家公式網www.70822.com}
趨勢:VOL,NODRAW;
MA5:MA(V,5),COLORWHITE; {5日均量線是主力啟動線}
MA10:MA(V,10),COLORYELLOW;{10日均量線是主力洗盤線,不同個股不同設置};
DRAWICON(CROSS(MA5, MA10),MA5,1);
DRAWICON(CROSS(MA10, MA5),MA10,2);

後台-系統-系統設置-擴展變量-(内容頁告位2-手機版)
聲明:本文内容由互聯網用戶自發貢獻自行上傳,本網站不擁有所有權,未作人工編輯處理,也不承擔相關法律責任。如果您發現有涉嫌版權的内容,歡迎發送郵件至本站聯系郵箱進行舉報,并提供相關證據,工作人員會在5個工作日内聯系你,一經查實,本站将立刻删除涉嫌侵權内容。
後台-系統-系統設置-擴展變量-(内容頁告位3-手機版)