新交易量(通達信公式 副圖 源碼 測試圖)(圖文)

時間:2019-09-22 13:17:12 作者:admin
後台-系統-系統設置-擴展變量-(内容頁告位1-手機版)

通達信指标 新交易量

M1:=3;
M2:=5;
M3:=10;
漲幅百分比:=1.25;
驗證寬容期:=1;
尾部驗證期:=240;
交易量:VOL,COLORRED,NODRAW;
{紅}
紅色條件0:=C>=O;
紅色條件1:=0;
紅色條件2:=VOL;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,3.0,0),COLOR0000FF;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,2.7,0),COLOR000077;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,2.1,0),COLOR000099;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,1.5,0),COLOR0000BB;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,0.9,0),COLOR0000DD;
STICKLINE(紅色條件0,紅色條件1,紅色條件2,0.3,0),COLOR0000FF;
{青}
青色條件0:=C<O;
青色條件1:=0;
青色條件2:=VOL;
STICKLINE(青色條件0,青色條件1,青色條件2,3.0,0),COLOREEEE00;
STICKLINE(青色條件0,青色條件1,青色條件2,2.7,0),COLOR666600;
STICKLINE(青色條件0,青色條件1,青色條件2,2.1,0),COLOR888800;
STICKLINE(青色條件0,青色條件1,青色條件2,1.5,0),COLORAAAA00;
STICKLINE(青色條件0,青色條件1,青色條件2,0.9,0),COLORCCCC00;
STICKLINE(青色條件0,青色條件1,青色條件2,0.3,0),COLOREEEE00;
{倍量柱}{www.70822.com}
倍量柱:=VOL>=REF(VOL,1)*1.91 AND C>REF(C,1)*1.01;
{粉}
粉色條件0:=倍量柱;
粉色條件1:=0;
粉色條件2:=VOL;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,3.0,0),COLORFF99FF;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,2.7,0),COLORFF55FF;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,2.1,0),COLORFF66FF;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,1.5,0),COLORFF77FF;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,0.9,0),COLORFF88FF;
STICKLINE(粉色條件0,粉色條件1,粉色條件2,0.3,0),COLORFF99FF;
{黃}
黃色條件0:=FILTER(倍量柱,3);
黃色條件1:=0;
黃色條件2:=VOL;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,3.0,0),COLOR00FFFF;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,2.7,0),COLOR0033FF;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,2.1,0),COLOR0066FF;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,1.5,0),COLOR0099FF;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,0.9,0),COLOR00CCFF;
STICKLINE(黃色條件0,黃色條件1,黃色條件2,0.3,0),COLOR00FFFF;
量背離:IF(VOL<REF(VOL,1) AND C>REF(C,1) AND REF(BARSLASTCOUNT(C<O)>=3,1),1,0),COLORWHITE;
STICKLINE(量背離,0,VOL,0,0),COLORWHITE;
MA03:MA(交易量,M1),COLORWHITE;
MA05:MA(交易量,M2),COLORYELLOW;
MA10:MA(交易量,M3),COLORMAGENTA;
XG:=量背離;
{買入條件}
買入條件:=XG>0;
{買入驗證條件}
比較收盤價:=C+(C*漲幅百分比/100);
買入寬容條件:=IF(驗證寬容期=1,REFX(C,1)>比較收盤價,
IF(驗證寬容期=2,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價),
IF(驗證寬容期=3,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價),
IF(驗證寬容期=4,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價),
IF(驗證寬容期=5,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價 OR REFX(C,5)>比較收盤價),
IF(驗證寬容期=6,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價 OR REFX(C,5)>比較收盤價 OR REFX(C,6)>比較收盤價),
IF(驗證寬容期=7,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價 OR REFX(C,5)>比較收盤價 OR REFX(C,6)>比較收盤價 OR REFX(C,7)>比較收盤價),
IF(驗證寬容期=8,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價 OR REFX(C,5)>比較收盤價 OR REFX(C,6)>比較收盤價 OR REFX(C,7)>比較收盤價 OR REFX(C,8)>比較收盤價),
IF(驗證寬容期=9,(REFX(C,1)>比較收盤價 OR REFX(C,2)>比較收盤價 OR REFX(C,3)>比較收盤價 OR REFX(C,4)>比較收盤價 OR REFX(C,5)>比較收盤價 OR REFX(C,6)>比較收盤價 OR REFX(C,7)>比較收盤價 OR REFX(C,8)>比較收盤價 OR REFX(C,9)>比較收盤價),DRAWNULL)))))))));
買入驗證:=買入條件 AND 買入寬容條件;
{買入标記}
DRAWICON(買入條件,0,1);
DRAWICON(買入驗證,0,9);
{買入統計}
全部周期:=TOTALBARSCOUNT,COLORRED,NODRAW;
間隔周期:=INTPART(全部周期/COUNT(買入條件,-1)),COLORGREEN,NODRAW;
買入次數:=COUNT(買入條件,-1);
正确次數:=COUNT(買入驗證,-1);
正确率%:=正确次數/買入次數*100,COLOR17ACFD,NODRAW;
顯示字符串:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(
'全部周期=',
CON2STR(全部周期,0)),
' 間隔周期='),
CON2STR(間隔周期,0)),
' 買入次數='),
CON2STR(買入次數,0)),
' 漲幅百分比%='),
CON2STR(漲幅百分比,2)),
' 正确次數='),
CON2STR(正确次數,0)),
' 正确率%='),
CON2STR(正确次數/買入次數*100,0)),
' 尾部驗證期='),
CON2STR(尾部驗證期,0)),
' 尾部正确率%='),
CON2STR(COUNT(買入驗證,尾部驗證期)/COUNT(買入條件,尾部驗證期)*100,0));
DRAWTEXT_FIX(1,0.2,0.02,0,顯示字符串),COLOR038CBA;

後台-系統-系統設置-擴展變量-(内容頁告位2-手機版)
聲明:本文内容由互聯網用戶自發貢獻自行上傳,本網站不擁有所有權,未作人工編輯處理,也不承擔相關法律責任。如果您發現有涉嫌版權的内容,歡迎發送郵件至本站聯系郵箱進行舉報,并提供相關證據,工作人員會在5個工作日内聯系你,一經查實,本站将立刻删除涉嫌侵權内容。
後台-系統-系統設置-擴展變量-(内容頁告位3-手機版)